PHP 5.3.10 sửa lỗ hổng thực thi mã từ xa nghiêm trọng

Discussion in 'Tin tức, sự kiện thường ngày' started by admin, Feb 8, 2012.

  1. admin

    admin Administrator Staff Member

    Joined:
    Oct 4, 2011
    Messages:
    22,247
    Likes Received:
    10,831
    Trophy Points:
    113
    [​IMG]
    Lỗ hổng này có thể bị khai thác để thực thi mã tùy ý trên những máy chủ đang chạy một phiên bản cũ của nền tảng phát triển web PHP. Hôm thứ Năm 2/2/2012, PHP Group đã phát hành PHP 5.3.10 nhằm giải quyết một lỗ hổng bảo mật nghiêm trọng. Lỗ hổng này có thể bị khai thác để thực thi mã tùy ý trên những máy chủ đang chạy một phiên bản cũ của nền tảng phát triển web PHP.Lỗ hổng được ký hiệu là CVE-2012-0830, do nhà tư vấn bảo mật độc lập Stefan Esser phát hiện. Ông Esser là tác giả của tiện ích mở rộng bảo mật Suhosin cho PHP.SecurityFocus xếp loại vấn đề này là một lỗi thiết kế vì người ta đã vô tình phát hiện nó khi sửa lỗ hổng từ chối dịch vụ (DoS) CVE-2011-4885 hồi đầu tháng 1/2012.CVE-2011-4885 được các nhà nghiên cứu bảo mật Alexander Klink và Julian Walđe tiết lộ hồi tháng 12/2011 tại Chaos Communication Congress. Nó ảnh hưởng đến một số nền tảng phát triển web như PHP, ASP.NET, Java, Python và có thể bị khai thác bằng phương thức tấn công Hash Collision DoS. Nhóm phát triển PHP đã giải quyết CVE-2011-4885 trong PHP 5.3.9, được phát hành vào ngày 10/1/2012.Lỗi CVE-2012-0830 có thể bị những kẻ tấn công khai thác để từ xa thực thi mã tùy ý trên hệ thống chạy bản PHP dễ bị tổn hại. PHP 5.3.9 cùng với bất kỳ phiên bản cũ nào chưa vá lỗi Hash Collision DoS đều bị ảnh hưởng.Mã khai thác lỗ hổng này đã được xuất bản trực tuyến, vì vậy khả năng xảy ra các cuộc tấn công nhắm vào CVE-2012-0830 là cao. Các nhà quản trị máy chủ web được khuyên nên nâng cấp lên PHP 5.3.10 ngay lập tức.
     

Share This Page